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1 Introduction 

SafeFit is part of the SafeSuite family of products, which aid in the development of projects 

following common industry’s safety standards. 

SafeFit focuses on the reliability prediction of electronic equipment. Reliability of a component 

is summarized in a so-called FIT value (Failure-in-time), which is calculated according to several 

rules from a chosen standard. 

SafeFit currently supports these reliability prediction standards: 

- IEC 62380 (International Electrotechnical Commission) 

- MIL 217F (USA Military) 

1.1 Features 

- Support for IEC62380, MIL217F. 

- Import/Export of data in CSV for interoperability with external programs. 

- Save/Load data in custom format enabling app-specific features. 

- Grid-based, single-view interface. 

- Fully keyboard and mouse enabled. Copy/Paste support to/from clipboard.  
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2 Usage 

2.1 Application parts 

 

1. Menu 

a. File > (New > (IEC-62380 | MIL-217F) | Load | Save | Import | Export | Exit) 

b. Help > (About | License) 

2. Standard’s global parameters 

3. General view grid 

4. Display component selector 

5. Detail view grid 

The above screenshot shows the initial state of the main window, which by default uses IEC-

62380. 

The global parameters section is standard-specific. Further details are discussed in their own 

section. There is a “Compute” button for quick batch recalculation when global parameters are 

changed. Per component re-calculation however, is also done after any row editing. 

The general view is intended for quick review of current loaded components. Supports sorting 

of its columns for easier navigation. 
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The detail view is where all components are added/removed, and its details edited. The current 

component type in display is selected through a combo box. Component types depend on the 

standard too, but are quite similar nonetheless. The grid supports sorting and column 

reordering. 

2.2 Licensing 

The application has three licensing states: 

- Unlicensed/invalid/expired license: in other words, no license. 

- Demo license: expires after a time interval (14 days). 

- Full license: lifetime license. 

The “No license” state blocks the Save, Import, Export features. Loading is still possible for 

demo purposes, but severely limits the application’s usability. 

A license can be requested with the “Help > License” dialog. The dialog shows brief instructions, 

which are hereby developed: 

1. Select the desired license type: either “Demo” or “Full”. The full license requires an order 

ID. 

2. Click the “Generate” button, which creates several files and opens their location on disk. 

3. Send the file named “LicenseRequest.dat” to the e-mail address support@safetwice.com 

4. The e-mail will be replied (if all is correct) with a file “License.dat”. Copy this file to the 

same place where the request is located. 

5. Close and reopen the program for the license to get detected.  

 

 

 

 

 

 

NOTICE: the license folder can be quickly found with the “Find” button in the “License” 
dialog. It should be in “C:\Users\<USER>\AppData\Local\SafeTwice\SafeFit\License”. 

NOTICE: to be able to regenerate the license request, if required, delete from disk the files 
“LicenseRequest.dat” and “PrivateKey”. 

NOTICE: the “.dat” extension is important. Add it in case it is missing in the 
“LicenseRequest” or “License” files. Otherwise the application will not properly recognize 
the license. 

mailto:support@safetwice.com
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2.3 Standard selection 

The currently used standard can be selected through the “File > New” menu. This clears current 

data and initializes the workspace for such standard. 

Additionally, when loading a project file, the appropriate standard for the project is loaded 

seamlessly. 

The current standard is always indicated in the app’s title bar. 

2.4 Detail view workflow 

There are four common columns used by all components: 

- Designator 

- FIT Def 

- FIT Comp 

- Description 

The designator value depends on the selected component and the standard. Valid values are 

shown in this document. However, they follow the rule: “<name><number>[<subitem>]” (R1, C1, 

U1A, …). 

- Name: standard designator, e.g. R – Resistor, C – Capacitor, etc. 

- Number: any positive number. 

- Subitem: optional upper-case letters for further categorization. 

- “FIT Def” stands for defined FIT, which is an independent cell included for 

reference/comparison purposes. 

- “FIT Comp” stands for computed FIT. These cells are not directly editable, but change 

according to the calculated FIT for the current input parameters. 

In general, a cell with invalid data, e.g. negative value for a positive only decimal value, is 

marked with a red border. 

NOTICE: a license is only valid for the computer it was generated in.the “.dat” extension is 
important. Add it in case it is missing in the  
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The application, according to the standard in use, groups components into single or groups of 

several electronic components, e.g. resistors or optoelectronics.  

The “Type” column is somewhat special and indicates the actual component type in groups of 

components, or component subgroup. This is very intuitive in general. 

Some columns may appear grayed out, meaning that its value is not necessary for the 

calculation of the FIT for the selected type. 

When all required values are filled in, the FIT is automatically computed. This is also the case 

when editing an existing value. However, global parameter changes require batch 

recomputation with the “Compute” button. 

The grid supports copy/paste both between itself and external programs, since it uses the 

system’s clipboard. Hence, data in the clipboard with tabular format (e.g. Excel) can be easily 

pasted into the program. Either row, column or rectangle selection is supported. Pasting 

however, will only work when the input data and the target cells have the same data types. The 

user can move data to/from Excel this way, for instance, and experiment with the feature. 

 

 

 

 

 

 

 

2.5 Import/export 

The application can read and write CSV files. This enables interoperability with external 

programs like Excel for instance. However, this becomes more interesting with the fact that PCB 

board designers like “Altium Designer” can export the BOM (bill of materials) in CSV with extra, 

QUICK TIPS: 

- Cells can be empty. Press “Backspace” key with a cell selected in order to clear it. 

- Rows are added filling in the cells of the last row and pressing “Enter” key. 

- A single row can be deleted fully selecting by clicking on the row header and pressing 

the “Del” key. 

- All rows of the displayed component can be deleted with “Right Click” > “Delete Rows”. 

- All cells of a column can be cleared with “Right Click” > “Clear Column”. 

- Similarly, copy and paste operations are available through the context menu (“Right 

Click”) as well as with the system’s usual “Ctrl-C”, “Ctrl-V” key shortcuts. 
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configurable parameters per component. Thanks to this, once the external program is correctly 

configured, the calculation of the FIT of all components in the BOM is quick and error-free. 

The CSV format requires a minimal compulsory header of just one column: “Designator”. All 

other columns are optional. Values of optional columns are also optional, i.e. empty values are 

allowed. 

There are columns of various types: 

- String: accepts any value, since CSV data is text by definition. 

- Decimal: integral or decimal values, in exponential notation too. 

- Enumerable (list): accepts either an integral value in the range of index values (zero-

based), or the exact string value of one of the items in the list. 

The type of a column is predefined and can be reviewed in the appendix of a given standard (in 

this document). Watch out for units in numeric values. 

Note: when importing CSV data, make sure that the app’s selected standard matches that of the 

CSV, or else there will be import errors (likely interrupting the import process). 

2.5.1 Import dialog 

 

A CSV file is selected by clicking “Browse” and searching for it with the usual system’s file 

explorer. 

The file is automatically parsed when browsed. If a path exists in the textbox and the user wants 

to reload it, it can be done by clicking “Parse”. 
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File contents can be imported completely (“Complete” option) or in parts (“Fixed” option plus 

individual component checkbox selection). 

Imported data components type and number can be reviewed easily. 

Imported data can either be appended (“Overwrite” unchecked) to existing data or it can replace 

existing data (“Overwrite” checked). 

Final importing into the current project dataset is done by clicking “Import”. 

2.5.2 Export dialog 

 

The current data set can be exported completely (“Complete” option) or in parts (other options). 

Included column headers depend on the selected option. “Complete” includes all columns. 

“Fixed” includes only those selected, independently of having existing items or not. “Current” 

exports current selected component in the detail view. “Compact” exports all with existing 

items. 

Select “Existing Only” to export only selected components with non-zero items. 

Click “Export” to accept and finish the export operation. 
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2.6 Save/load 

The project file has “.sfit” extension. This file enables app-specific functionality that CSV 

import/export features cannot provide. Among other features, it stores the current standard in 

use and its global parameters. 

Save/load of project files is done through the “File” menu. 

3 IEC 62380 

Global parameters for IEC-62380 are called “Mission Profile”. These include several thermal 

phases (each characterized by an Ambient Temperature and a time ratio Tau) and several 

thermal cycles (each characterized by a temperature Delta, a Number of cycles, and a Dormant 

parameter). 

Standard mission profiles from the IEC 62380 TR can be easily selected through the “cog” button 

(mission profile settings). After any change, the “Compute” button must be clicked for a 

complete recalculation. 

The “Delta Temperature” parameter of the mission profile can be overridden in some 

components of the standard that include an auto-heating term in their FIT formulae. The 

appropriate column is “Delta T” (in Celsius). 

 

 

 

 

 

For a complete list of components, designators, parameters and values, see the appropriate 

standard reference for SafeFit. 

NOTICE: “Delta T” override functionality can be used to apply a complex thermal scheme to 
the calculated system. When empirical auto-heatings are not available, SafeFIT will use 
calculated predictions based on component characteristics and electrical operating 
conditions. 

NOTICE: “Dormant” check box can be used to define a thermal cycle for a dormant or off 
state of the system (no auto-heating considered). Please check IEC 62380 TR for further 
information. 
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4 MIL 217F 

This standard’s global parameters are only “Ambient Temperature” and “Environment” type. 

Many components have “Type” and “Style” (or subtype) columns. Parameter values that are 

input via a list require a component’s type to be committed before allowing further input. Make 

sure to press enter (commit) after creation of a component with its type before filling in the 

rest of the parameters. This also sets up the appropriate parameter vs. type sensitivities. 

In general, “Type”, “Style” and “Quality” columns are shared among most of the components 

of the standard. 

The profile’s ambient temperature is overridable in many components using the “Tamb” column. 

 

 

 

Several components with an auto-heating factor provide two ways to input the auto-heating 

required parameters: either use “Power” and “Rth”, or “Tj” (junction temperature – has 

precedence). 

 

 

 

For a complete list of components, designators, parameters and values, see the appropriate 

standard reference for SafeFit. 

NOTICE: “Tamb” override functionality can be used to apply a complex thermal scheme to 
the calculated system. When empirical temperature measures are not available, SafeFIT will 
use calculated predictions based on component characteristics and electrical operating 
conditions. 

NOTICE: When “Tj” is provided, SafeFit will use it to calculate component’s self-heating.  
When it is not provided, SafeFit will do calculations based on thermal resistance (Rth) and 
electrical power (Power). 


